bounceHammer has been EOL'ed on February 29, 2016

Sisimai
Commercial Support

  • 1Setting Up Sisimai Your Server
  • 2Support developmenet using Sisimai
  • 3Support via Email
  • 4Support bounce management
  • 5Parsing your bounced emails

bounceHammer 2.7.11

2013/10/22 Released

bounceHammer 2.7.11 Release

bounceHammer 2.7.11 has been released.


To get the files for this release, see Download page. RELEASE_NOTS[English] has a list of all changes between previous version of bounceHammer and 2.7.11.

A Patial List of Changes

Assorted improvements and code cleanup

  • Output data (json,yaml, and csv) created by mailboxparser command includes the new sub fields: subject(the value of Subject header) and messageid (the value of Message-Id header) in the description field.
  • Update cellular phone domains, such as SMS or MMS gateways
  • mailboxparser now can parse an bounce email from Gmail with DNS error
  • Improved Analytical accuracy of Gmail, Exim, Sendmail, and qmail
  • mailboxparser now can parse a bounce email from @vtext.com, and @vzwpix.com ( Verizon Wireless ) by MTA::US::Verizon module based on MTA::US::Vtext at Pull request #3 from scottgifford.
    Thanks to Scott Gifford.
  • Update error message patterns in Kanadzuchi/Mail/Why
  • @yahoo.ne.jp is classified into provider 'yahoo'
  • Improved precision of analysis for bounce emails from au by KDDI (@ezweb.ne.jp: Japanese cellular phone provider) and Yahoo!

Fixed Bugs

  • Fixed an issue that make test fails when there is no DBD::SQLite module in @INC on t/024_statistics-stored-bddr.t.
    Thanks to Tateyama.
  • Fixed an issue that Kanadzuchi::Time cannot parse the following date format: 25 May 2013 1:2

New files

  • lib/Kanadzcuhi/MIME.pm
  • lib/Kanadzuchi/MTA/US/Verizon.pm
  • lib/Kanadzuchi/Mail/Why/Suspend.pm
  • t/027_mime.t
  • t/043_mta-us-verizon.t

Removed files

  • lib/Kanadzuchi/Mail/Bounced/Yahoo.pm

Upgrading to bounceHammer 2.7.11

Get the tarball of bounceHammer 2.7.11 release from Download page. If there is any patch for version 2.7.11, download patches and apply before running the progmam: configure, make.

To upgrade to bounceHammer 2.7.11 from the previous version or older, you overwrite the previous version like the following:

# export PERL5LIB=/usr/local/bouncehammer/lib/perl5 <- If you needed
# ./configure <- with the same option of currenlty installed version
# make
# make test && make install